История версий ifClient for 3СX Phone System v14

ifClient for 3CX v14 SP2 и SP3 версия 3.2.1.0 от 28.10.2016

Новое в релизе.

1. Окончательный релиз внешнего компонента для 1С по технологии Native API.
2. Адаптер внешнего компонента для Google Chrome и Firefox.
3. COM компонент переработан с учетом его использования в нативном компоненте.

Устранены ошибки.

1. Крах ifClient.exe в версии 3.2.0.1.


ifClient for 3CX v14 SP2 и SP3 версия 3.2.0.0 от 09.08.2016

!!! Плагин ifClient Plugin 3.2.0.0 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3 !!!

Новое в релизе.

1. Бета версия Внешнего компонента для 1С по технологии Native API - ifClient1CNative.dll:
     - реализованы методы:
         - GetUserProfiles() - запрос профилей пользователя;
         - SetChatMessagesReceivedStr() - аналог SetChatMessagesReceived со строковым параметром.
     - реализовано событие:
         - profile - профиль пользователя.
     Пример использования нативного внешнего компонента :
     ПодключитьВнешнююКомпоненту("C:\Program Files (x86)\Interface Ltd\ifClient for 3CX\ifClient1CNative.dll", "ifClient", ТипВнешнейКомпоненты.Native);
     ВК = Новый("AddIn.ifClient.ifClient");

Устранены ошибки.

1. Не удаляются групповые чаты.
2. Перепрофилирована защита - многократное открытие-закрытие не встроенной в конфигурацию Панели телефонии для 1С может привести к краху 1С.

Известные проблемы.

1. При использовании нативного компонента для 1С,  без вызова метода Disconnect долгое закрытие 1С или долгое первое закрытие не встроенной в конфигурацию Панели для 1С.
    Решение проблемы - используйте обработчик ожидания. Пример решения:
     Перем ФлагЗакрытия;
     
     Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
         ФлагЗакрытия = Ложь;
     КонецПроцедуры
     
     Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
         Если Не ФлагЗакрытия Тогда
             ВК.Disconnect();
             Отказ = Истина;
             ПодключитьОбработчикОжидания("ОбработчикОжиданияОтключения", 1, Истина);
         Иначе
             ВК = Неопределено;
         КонецЕсли;
     КонецПроцедуры

     Процедура ОбработчикОжиданияОтключения()
         ФлагЗакрытия = Истина;
         Закрыть();
     КонецПроцедуры


ifClient for 3CX v14 SP2 и SP3 версия 3.1.1.0 от 04.08.2016

Новое в релизе.

1. Получение списка чатов оператора:
     - метод GetChats / cmd=getchats;
     - событие chat.


ifClient for 3CX v14 SP2 и SP3 версия 3.1.0.0 от 02.08.2016

!!! Плагин ifClient Plugin 3.1.0 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3 !!!

Новое в релизе.

1. Групповой чат:
     - для передачи сообщения нескольким абонентам в методе SendChatMessage() абоненты в параметре <Абоненты> должны быть перечислены через запятую;
     - для удаления группового чата <Абоненты> должны быть перечислены через запятую;
     - в события chatmessage и chathistory добавлен новый ключ party - список участников группового чата;
2. Изменен тип параметра <Дата с> в методе GetChatMessages() со string на nullable DateTime.
3. Удаление массива сообщений чата - изменен параметр в методе SetChatMessagesReceived с int на int[].
4. Изменен источник в событиях chatmessage и chathistory на chat.
5. Расширен состав команд для интеграции через WebSocket сервер:
     - cmd=deletehatmessages;
     - cmd=getchatmessages;
     - cmd=sendchatmessage;
     - cmd=setchatmessagesreceived.
6. Оптимизация кода.

Устранены ошибки.

1. Крах 1С при последовательном вызове методов GetCallHistory и GetChatMessages COM-объекта.


ifClient for 3CX v14 SP2 и SP3 версия 3.0.1.1 от 25.07.2016

Устранены ошибки.

1. При интеграции через WebSocket не учтена регистрозависимость пароля пользователя.
2. Ошибка опроса Trial ключа в версии 3.0.1.0.


ifClient for 3CX v14 SP2 и SP3 версия 3.0.1.0 от 20.07.2016

!!! Плагин ifClient Plugin 3.0.1 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3 !!!

Новое в релизе.

1. Расширен состав команд для интеграции через WebSocket сервер:
     - cmd=getcallhistory;
     - cmd=getcallhistorybydate;
     - cmd=playmyrecord;
     - cmd=playmyrecordonphone.

Устранены выявленные ошибки и недочеты.


ifClient for 3CX v14 SP2 и SP3 (WebAPI Client for 3CX) версия 3.0.0 от 10.07.2016

!!! Плагин ifClient Plugin 3.0.0 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3 !!!

Новое в релизе.

1. Смена названия продукта на "ifClient for 3CX".
2. Самостоятельное приложение.
3. WebSocket сервер с поддержкой SSL.
4. Трансляция событий через WebSocket сервер, обработка команд, полученных через WebSocket сервер.
5. Работа с автосекретарями:
     - события о соединениях на автосекретаре;
     - сброс и перевод соединений на автосекретаре.
6. Расширено управление CTI телефонами:
     - метод DNDOnCTI() - включить режим DND;
     - метод DNDOffCTI() - выключить режим DND.

Устранены выявленные ошибки и недочеты.


WebAPI Client for 3CX v14 SP2 и SP3 версия 2.8.0.2 от 05.07.2016

!!! Плагин WebAPI_3CX_1C_Plugin.dll 2.8.0.2 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3!!!

Устранены выявленные ошибки. Оптимизирован код.


WebAPI Client for 3CX v14 SP2 и SP3 версия 2.8.0.1 от 01.07.2016

!!! Плагин WebAPI_3CX_1C_Plugin.dll 2.8.0.1 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3!!!

Устранены выявленные ошибки.


WebAPI Client for 3CX v14 SP2 и SP3 версия 2.8.0 от 24.06.2016

!!! Плагин WebAPI_3CX_1C_Plugin.dll 2.8.0 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3!!!

Устранены ошибки в Trial версии.

1. Блокируется работа с телефонами в триальной версии (заполнение списка зарегистрированных телефонов, отправка команд телефонам).


WebAPI Client for 3CX v14 SP2 и SP3 версия 2.8.0 от 11.06.2016

!!! Плагин WebAPI_3CX_1C_Plugin.dll 2.8.0 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3 !!!

Новое в релизе.

1. Реализован работа с записями собственных вызовов оператора:
     - в событие callhistory добавлен новый ключ recfile - имя фала записи вызова;
     - в событие localconnection добавлен новый ключ recfile - имя фала записи вызова, событие возникает при установлении соединения;
     - реализованы методы:
         - PlayMyRecord() - сохранить файл локально и открыть его в медиапроигрывателе;
         - PlayMyRecordOnPhone() - воспроизвести запись вызова на телефоне.
2. Свойство CallerIdMinMatch - минимальное количество цифр в номере телефона для идентификации при поиске в истории и записях вызовов. CallerId сравниваются справа налево по количеству цифр, заданных CallerIdMinMatch. По умолчанию 10 (оптимальное значение).
3. Реализовано событие callhistory для завершившегося вызова. Событие происходит только после завершения всей цепочки соединений в вызове (при завершении последнего соединения с данным callid).
4. Свойство RequestTimeOut - время ожидания ответа от Web сервиса, после которого происходит разрыв соединения. В 3CX по умолчанию 30 секунд.
5. Попытка автоматического переподключения к АТС после разрыва соединения.
6. Переработана выдача событий:
     - отдельный, одновременный вывод событий для собственных соединений пользователя, соединений в группах пользователя и соединений в очередях;
     - струтурирован параметр "Событие" в событии OnEvent:
         - myinfo - события о собственных соединенииях оператора;
         - group - события о группах абонентов, участниках групп и соединений у участников групп, в том числе и собственных соединений абонента;
         - queue - события об очередях, участниках очередей и соединений в очередях, в том числе и собственных соединений абонента;
     - увеличено быстродействие выдачи событий.

Устранены выявленные ошибки и недочеты.


WebAPI Client for 3CX v14 SP2 и SP3 версия 2.7.1 от 18.04.2016

!!! Плагин WebAPI_3CX_1C_Plugin.dll 2.7.1 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3!!!

Новое в релизе.

1. Реализовано свойство OnlyMyConnection - не передавать события localconnection, которые не относятся к пользователю.

Устранены ошибки.

1. Ошибка "GuardantDotNetApi.dll not found" - в некоторых случаях компонент не находит библиотеку GuardantDotNetApi.dll.


WebAPI Client for 3CX v14 SP2 и SP3 версия 2.7.0 от 28.03.2016

!!! Плагин WebAPI_3CX_1C_Plugin.dll 2.7.0 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3!!!

Новое в релизе.

1. Получение истории вызовов пользователя с возможностью фильтрации по типу вызова (входящий, исходящий, пропущенный) и номерам телефонов (RegExp)
     - реализованы методы:
         - GetCallHistory() - получить с заданной позиции в истории заданное количество записей;
         - GetCallHistoryByDate() - получить историю за определенный период;
     - реализовано событие:
         - callhistory - получена история, вызовы cортируются в хронологическом порядке от поздней даты к ранней.
2. Метод SendDTMF3CXPhoneByCallId() - возможности посыла DTMF по неактивной линии и по активной линии с вызовом на удержании.
3. В событие localconnection добавлен новый ключ devicecontact - SIP Uri устройства, к которому  относится событие.
4. В событие 3cxphonecall добавлен новый ключ callstate - состояние вызова, значения:
     - hold - вызов поставлен на удержание;
     - held - вызов поставлен на удержание другим абонентом;
     - established - вызов активен (снят с удержания).


WebAPI Client for 3CX v14 SP2 и SP3 версия 2.6.0.2 от 17.03.2016

!!! Плагин WebAPI_3CX_1C_Plugin.dll 2.6.0.2 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3!!!

Устранены ошибки.

1. Не происходит обмен данными между компонентом и плагином через именованный канал


WebAPI Client for 3CX v14 SP2 и SP3 версия 2.6.0.1 от 14.03.2016

!!! Плагин WebAPI_3CX_1C_Plugin.dll 2.6.0.1 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3!!!

Новое в релизе.

1. Для сетевых лицензий путь к файлу сетевых настроек клиента Guardant (gnclient.ini) задается через переменную окружения IFCLIENT.
2. Увеличен интервал опроса ключа для снижения нагрузки на сервер лицензирования.

Исправлены выявленные ошибки.


WebAPI Client for 3CX v14 SP2 и SP3 версия 2.6.0 от 10.03.2016

Компонент переработан для совместимости с 3CX Phone System SP3. !!! Плагин WebAPI_3CX_1C_Plugin.dll 2.6.0 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 и SP3!!!

Новое в релизе.

1. Расширено управление софтфоном 3CXPhone
     - реализованы методы:
         - SendDTMF3CXPhoneByCallId() - посыл DTMF.
2. Переработан обмен между компонентом и плагином для устранения проблемы большой времени реакции плагина на команды компонента и передачей событий плагином компоненту. При возможности обмен происходит через Named Pipes (плагин - сервер, компонент - клиент). При недоступности Named Pipes по каким-либо причинам обмен происходит как и прежде через АТС, но без задержки.
     - в событие plugin добавлены ключи:
         - id - Id устройства;
         - channel - тип канала (на текущий момент значение всегда "pipe");
         - state - состояние канала "connected | error";
         - msg - описание ошибки.
3. Переработан AddIn для 1С.
4. Переработан установщик.
     - выборочная установка компонента и плагина;
     - установка всех файлов кроме плагина в отдельный каталог (%PROGRAMFILES(x86)%\Interface Ltd\WebAPI Client for 3CX);
     - удаление ссылки на плагин из конфигурационного файла 3CXPhone при деинсталляции.
5. Изменена схема лицензирования продукта. Плагин для 3CXPhone требует приобретения дополнительной лицензии для плагина. Для пользователей, имеющих действующую подписку на обновления, сохраняется старая схема лицензирования.

Устранены ошибки.

1. Значительное замедление скорости реакции плагина на команды от компонента в v14 SP1 и SP2.
2. Не отрабатывает метод DropCall3CXPhoneByCallId.


WebAPI Client for 3CX v14 SP2 версия 2.5.0 от 27.01.2016

Компонент переработан для совместимости с 3CX Phone System SP2. !!! Плагин WebAPI_3CX_1C_Plugin.dll 2.5.0 совместим только с софтфоном, идущим в составе 3CX Phone System SP2 !!!

Новое в релизе.

1. Расширено управление софтфоном 3CXPhone
     - реализованы методы:
         - MakeCall3CXPhone() - исходящий вызов;
         - AnswerCall3CXPhoneByCallId() - ответ на входящий вызов по Id вызова;
         - DropCall3CXPhoneByCallId() - отбой вызова по Id вызова;
         - HoldCall3CXPhone() - удержание / снятие с удержания активного вызова;
         - BlindTransfer3CXPhoneByCallId() - слепой перевод вызова по Id вызова;
         - AttendantTransfer3CXPhoneByCallId() - перевод вызова с консультацией по Id вызова;
         - FinalizeTransfer3CXPhoneByCallId() - завершение перевода вызова с консультацией по Id вызова;
         - CancelTransfer3CXPhoneByCallId() - отмена перевода вызова с консультацией по Id вызова.
2. Работа с профилем
     - реализованы свойства:
         - UserProfilesList - список профилей;
         - CurrentProfileId - получение / установка текущего профиля;
     - в событие groupmember добавлены ключи:
         - currentprofile - наименование текущего профиля пользователя;
         - currentprofileinternalname - внутреннее наименование в АТС текущего профиля пользователя;
3. Работа с устройствами
     - реализованы свойства:
         - UserPhonesList - список зарегистрированных устройств под текущим аккаунтом;
         - CurrentPhoneId - получение Id текущего устройства / установка текущего устройства;
     - реализовано событие phone:
         - action=add - устройство зарегистрировалось на АТС и добавлено в UserPhonesList;
         - action=delete - произошли разрегистрация устройства и удаление из UserPhonesList;
         - action=set - устройство выбрано в качестве текущего.
     Отпала необходимость указывать в 1С тип устройства. Возможность выбирать текущее устройство в процессе работы без переподключения к 3CX.
4. Переработаны функции подключения к АТС
     - реализовано событие channel:
         - state=connected - произошло подключение к АТС;
         - state=disconnected - произошло отключение от АТС;
         - state=error - произошла ошибка.
     Отпала необходимость в задержке (в обработчиках ожидания) для получении первичной информации от АТС после вызова метода Connect().
5. Изменена работа с плагином для софтфона 3CXPhone.
     - реализовано событие plugin - 3CXPhone загрузил плагин.
     Отпала необходимость использовать свойство UsePlugin. UsePlugin необходимо использовать если для исходящего вызова через софтфон используется метод MakeCall2.

Устранены ошибки.

1. Невозможно сбросить исходящий вызов нажатием кнопки "Завершить" на 3CXPhone, если вызов осуществлен из 1С по первой линии софтфона.
2. При повтором вызове метода Connect() происходит дублирование событий.


WebAPI Client для 3CX v14 и v14 SP1 версия 2.0.3 от 03.12.2015

Устранены ошибки.

1. Устранены ошибки в регистрации COM объекта.


WebAPI Client для 3CX v14 и v14 SP1 версия 2.0.2 от 22.10.2015

Версия протестирована на совместимость с 3CX Phone System SP1.

Новое в релизе.

1. Заблокирована генерация плагином события 3cxphonecall с ключем state=Deleted. Удаление вызова в CRM осуществляйте по событию localconnection c ключем action=delete.

Устранены ошибки.

1. Устранены ошибки в выдаче событий 3cxphonecall c state=Ringing, state=Dialing, state=Connected (повтор одинаковых событий, эпизодическое отсутствие событий).


WebAPI Client для 3CX v14 версия 2.0.1 от 14.10.2015

Новое в релизе.

1. Подпись сборок сертификатом Code Signing.

Устранены ошибки.

1. В событии localconnection не приходит ключ answeredat.
2. При рассинхронизации времени между АТС и клиентским ПК неверно рассчитывается длительность вызова.
3. Невозможно определить причину неудачного подключения к АТС. Переработана выдача сообщений об ошибках при подключении к АТС.


WebAPI Client для 3CX v14 версия 2.0.0 от 01.10.2015

Новое в релизе.

1. Поддержка 3CX Phone System v.14
2. Управление аппаратными телефонами, поддерживающими режим CTI:
     - реализовано свойство:
         - IsSupportsCTI - поддержка CTI;
     - реализованы методы:
         - SupportedCTICommands() - получение информации о поддерживаемых телефоном командах;
         - SpeakerOnOffCTI() - включение/отключение громкой связи;
         – AnswerCallCTI() - ответ на входящий вызов;
         – DropCallCTI() - отбой вызова;
         – MakeCallCTI() - осуществление вызова;
         – BlindTransferCTI() - слепой перевод вызова;
         – AttendantTransferCTI() - перевод с консультацией;
         – FinalizeTransferCTI() - завершить перевод с консультацией;
         – HoldCTI() - удержание, снятие с удержания;
         – MuteCTI() отключение/включение микрофона;
         – PressDialKeyCTI() - нажатие цифры/последовательности цифр на номеронабирателе;
         – PressLineKeyCTI() - выбор SIP аккаунта.
3. Расширены функции управление софтфоном 3CXPhone:
     - реализованы методы:
         - AnswerCall3CXPhone() - ответить по указанной линии;
         - ChangeLine3CXPhone() - переключить линию;
         - DropCall3CXPhone() - сбросить вызов на указанной линии;
         - GetLinesStatus3CXPhone() - получить статусы линии/линий;
     - реализованы события:
         - 3cxphonecall - произошло изменение статуса линии / запрос состояния линии;
         - 3cxphoneline - произошло измение текущей линии на 3CXPhone.

Устранены ошибки.

1. Многократный вызов методов Connect() и Disconnect() приводит к краху компонента.
2. При использовании 3CXPhone и плагина WebAPI_3CX_1C_Plugin метод DropCall(<Id соединения>) сбрасывает на софтфоне текущий вызова вместо вызова, у которого Id  равен параметру <Id соединения>.