История версий ifClient for 3СX Phone System v15

ifClient for 3CX v15 версия 3.2.1.0 от 28.10.2016

Новое в релизе.

1. Окончательный релиз внешнего компонента для 1С по технологии Native API.
2. Адаптер внешнего компонента для Google Chrome и Firefox.
3. COM компонент переработан с учетом его использования в нативном компоненте.

Устранены ошибки.

1. Крах ifClient.exe в версии 3.2.0.1.


ifClient for 3CX v15 версия 3.2.0.0 от 09.08.2016

Новое в релизе.

1. Бета версия Внешнего компонента для 1С по технологии Native API - ifClient1CNative.dll:
     - реализованы методы:
         - GetUserProfiles() - запрос профилей пользователя;
         - SetChatMessagesReceivedStr() - аналог SetChatMessagesReceived со строковым параметром.
     - реализовано событие:
         - profile - профиль пользователя.
     Пример использования нативного внешнего компонента :
     ПодключитьВнешнююКомпоненту("C:\Program Files (x86)\Interface Ltd\ifClient for 3CX\ifClient1CNative.dll", "ifClient", ТипВнешнейКомпоненты.Native);
     ВК = Новый("AddIn.ifClient.ifClient");

Устранены ошибки.

1. Не удаляются групповые чаты.
2. Перепрофилирована защита - многократное открытие-закрытие не встроенной в конфигурацию Панели телефонии для 1С может привести к краху 1С.

Известные проблемы.

1. При использовании нативного компонента для 1С,  без вызова метода Disconnect долгое закрытие 1С или долгое первое закрытие не встроенной в конфигурацию Панели для 1С.
    Решение проблемы - используйте обработчик ожидания. Пример решения:
     Перем ФлагЗакрытия;
     
     Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
         ФлагЗакрытия = Ложь;
     КонецПроцедуры
     
     Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
         Если Не ФлагЗакрытия Тогда
             ВК.Disconnect();
             Отказ = Истина;
             ПодключитьОбработчикОжидания("ОбработчикОжиданияОтключения", 1, Истина);
         Иначе
             ВК = Неопределено;
         КонецЕсли;
     КонецПроцедуры

     Процедура ОбработчикОжиданияОтключения()
         ФлагЗакрытия = Истина;
         Закрыть();
     КонецПроцедуры


ifClient for 3CX v15 версия 3.1.1.0 от 04.08.2016

Подтверждена совместимость с 3CXPhone System v15 SP1

Новое в релизе.

1. Получение списка чатов оператора:
     - метод GetChats / cmd=getchats;
     - событие chat.


ifClient for 3CX v15 версия 3.1.0.0 от 02.08.2016

Новое в релизе.

1. Групповой чат:
     - для передачи сообщения нескольким абонентам в методе SendChatMessage() абоненты в параметре <Абоненты> должны быть перечислены через запятую;
     - для удаления группового чата <Абоненты> должны быть перечислены через запятую;
     - в события chatmessage и chathistory добавлен новый ключ party - список участников группового чата;
2. Изменен тип параметра <Дата с> в методе GetChatMessages() со string на nullable DateTime.
3. Удаление массива сообщений чата - изменен параметр в методе SetChatMessagesReceived с int на int[].
4. Изменен источник в событиях chatmessage и chathistory на chat.
5. Расширен состав команд для интеграции через WebSocket сервер:
     - cmd=deletehatmessages;
     - cmd=getchatmessages;
     - cmd=sendchatmessage;
     - cmd=setchatmessagesreceived.
6. Оптимизация кода.

Устранены ошибки.

1. Крах 1С при последовательном вызове методов GetCallHistory и GetChatMessages COM-объекта.


ifClient for 3CX v15 версия 3.0.1.1 от 25.07.2016

Устранены ошибки.

1. При интеграции через WebSocket не учтена регистрозависимость пароля пользователя.
2. Ошибка опроса Trial ключа в версии 3.0.1.0.


ifClient for 3CX v15 версия 3.0.1.0 от 20.07.2016

1. Поддержка 3CX Phone System v.15