Обновление ifClient for 3CX v14 и v15 до версии 3.2

Новое в релизе

Новое в релизе.

1. Бета версия Внешнего компонента для 1С по технологии Native API - ifClient1CNative.dll:
     - реализованы методы:
         - GetUserProfiles() - запрос профилей пользователя;
         - SetChatMessagesReceivedStr() - аналог SetChatMessagesReceived со строковым параметром.
     - реализовано событие:
         - profile - профиль пользователя.
     Пример использования нативного внешнего компонента :
     ПодключитьВнешнююКомпоненту("C:\Program Files (x86)\Interface Ltd\ifClient for 3CX\ifClient1CNative.dll", "ifClient", ТипВнешнейКомпоненты.Native);
     ВК = Новый("AddIn.ifClient.ifClient");

Устранены ошибки.

1. Не удаляются групповые чаты.
2. Перепрофилирована защита - многократное открытие-закрытие не встроенной в конфигурацию Панели телефонии для 1С может привести к краху 1С.

Известные проблемы.

1. При использовании нативного компонента для 1С,  без вызова метода Disconnect, долгое закрытие 1С или долгое первое закрытие не встроенной в конфигурацию Панели для 1С.
    Решение проблемы - используйте обработчик ожидания. Пример решения:
     Перем ФлагЗакрытия;
     
     Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
         ФлагЗакрытия = Ложь;
     КонецПроцедуры
     
     Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
         Если Не ФлагЗакрытия Тогда
             ВК.Disconnect();
             Отказ = Истина;
             ПодключитьОбработчикОжидания("ОбработчикОжиданияОтключения", 1, Истина);
         Иначе
             ВК = Неопределено;
         КонецЕсли;
     КонецПроцедуры

     Процедура ОбработчикОжиданияОтключения()
         ФлагЗакрытия = Истина;
         Закрыть();
     КонецПроцедуры